AnyBackup-Microsoft SQL Server authentication fails with error:Login failed for user 'test'. Reason The password of the account must be changed.
Introduction: Microsoft SQL Server authentication fails with error:Login failed for user 'test'. Reason The password of the account must be changed. To resolve this issue, change the password of the account.
Keywords
SQL Server authentication、account
Applied Versions
· AnyBackup 6.0.x
· AnyBackup 5.0.x
· EBackup 5.0.x
Symptoms
In AnyBackup, when you try to use SQL Server Authentication mode to authorize SQL Server data sources, it fails and prompts the following error:
Login failed for user 'test'. Reason: The password of the account must be changed.
Impact
AnyBackup SQL Server data sources authentication fails.
Cause
The password of the account to log in to Microsoft SQL Server database has expired.
Resolution
To resolve this issue,the password of the account needs to be changed in SQL Server Management Studio. To change the password of the account, please follow the steps below:
Note: As shown in the following steps, the account name is 'test' for example.
1. Log in to the target Windows operating system.
2. Click Start, open SQL Server Management Studio.
3. In Connect to Server login window, select SQL Server Authentication in Authentication options, input account test and password, then click Connect.
4. In the pop-up Change Password window, input new password and confirm it, then click OK.
5. Log in to AnyBackup console, and authorize SQL Server data sources again by the account and new password.
More Information
Microsoft SQL Server database has password expiration option while creating a new account. The password may expire after some time while enforcing the password expiration option. For more information of SQL Server authentication password expiration, please refer to Microsoft SQL Server article: Password Expired.