AnyBackup AnyBackup 7.0 The background display of snapshot pool and data volume status is abnormal due to the expiration of eab user's password.
Introduction: It can be solved by changing the password validity period of the eab user in the background of the AnyBackup console system to permanent.
Keywords
Volume exception, snapshot pool exception, eab, password validity
Applied Products
- AnyBackup CDM 7.0.x
- AnyBackup Express 7.0.x
- AnyBackup Cloud 7.0.x
Symptoms
The login admin user of the AnyBackup management console finds that the status of the snapshot pool and volume is abnormal; Check the message log of the background operating system on the AnyBackup console, and the message log displays the words NULL pam handle passed;
execute command Systemctl status -i ABStorageResMgmService output: pam_unix ( sudo:account ) : expired password for user eab ( password aged )
Impact
All backups failed.
Cause
The password of the operating system user eab of the AnyBackup backup server expires.
Resolution
To solve this problem, it is necessary to modify the password validity of eab, the operating system user of the AnyBackup server, to be permanent. Please follow the steps below:
1. Log in to the node background of the AnyBakcup backup server with root ssh, and execute the following command to check the validity period of the eab user's password:
chage -l eab
2. Execute the following command to change the validity of the eab user's password to permanent:
chage -M 99999 eab
More information
By default, users' passwords are permanent in the apollo system. However, when users install their own Linux operating system, the validity period of the user's passwords is not necessarily permanent. The AnyBackup management console requires that the eab password in the operating system is permanent and does not expire.