AnyBackup-AnyBackup 7.0 web administrator user is locked with the initial password and then an error message is displayed when using a script to unlock: The username admin uninitialized password.
Introduction: AnyBackup 7.0 web-side administrator user is locked with an initial password and then unlocks with a script, and an error message is displayed: The username admin uninitialized password. You can enter the background database to modify the locked state.
Keywords
Admin user, initial password, lock
Applied Products
- AnyBackup CDM 7.0.5-7.0.12
- AnyBackup Express 7.0.5-7.0.12
Symptoms
After the web administrator user is locked with the initial password, an error message is displayed when using the script to unlock:
The username admin uninitialized password.
Note: The admin user is used as an example here, and the specific information is subject to the actual environment.
Impact
Admin users cannot log in to the web, and reset password scripts cannot unlock users.
Cause
Reset password script cannot unlock admin user with initial password.
Resolution
To solve this problem, you need to log in to the backend database of the AnyBackup backup server, change the locked value of the user table in the AuthServiceDB library to 0, and delete the data in the lock_user table. The operation steps are as follows:
1. Log in to the backend database of the AnyBackup backup server, execute use AuthServiceDB; select the AuthServiceDB database.
2. Execute the select username,locked from user\G; command to query the account lock information recorded in the user table in the AuthServiceDB database.
3. Execute update user set locked=0 where locked=1; Change the locked value to 0 to change the locked status of the account
4. Repeat step 2 to confirm that the locked field in the user table has been updated.
5. Execute the select * from lock_user; command to query the information recorded in the lock_user table.
6. Execute the delete from lock_user; command to delete all account lock information.
More information
The default password for the admin user is P@ssword123. Prior to AnyBackup version 7.0.12, if the admin user was locked with the default password, it could not be unlocked directly using a script. Starting from AnyBackup version 7.0.13, new scripts are available for user unlock and password reset.